
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
The Arduino Duemilanove ("2009") is a microcontroller board based on the ATmega328. It has 14 
digital input/output pins (of which 6 can be used as PWM outputs), 6 analog inputs, a 16 MHz 
crystal oscillator, a USB connection, a power jack, an ICSP header, and a reset button. It contains 
everything needed to support the microcontroller; simply connect it to a computer with a USB 
cable or power it with a AC-to-DC adapter or battery to get started.  

"Duemilanove" means 2009 in Italian and is named after the year of its release. The Duemilanove 
is the latest in a series of USB Arduino boards; for a comparison with previous versions, see the 
index of Arduino boards.  

 

 

 

 

 

 

 

http://arduino.cc/en/Main/Boards


 

EAGLE files: arduino-duemilanove-reference-design.zip Schematic: arduino-duemilanove-schematic.pdf 

 

Microcontroller ATmega328 

Operating Voltage 5V 

Input Voltage (recommended) 7-12V 

Input Voltage (limits) 6-20V 

Digital I/O Pins 14 (of which 6 provide PWM output) 

Analog Input Pins 6 

DC Current per I/O Pin 40 mA 

DC Current for 3.3V Pin 50 mA 

Flash Memory 32 KB of which 2 KB used by bootloader

SRAM 2 KB  

EEPROM 1 KB  

Clock Speed 16 MHz 

 
 

 

http://arduino.cc/en/uploads/Main/arduino-duemilanove-reference-design.zip
http://arduino.cc/en/uploads/Main/arduino-duemilanove-schematic.pdf


 
The Arduino Duemilanove can be powered via the USB connection or with an external power supply. The 
power source is selected automatically.  

External (non-USB) power can come either from an AC-to-DC adapter (wall-wart) or battery. The adapter 
can be connected by plugging a 2.1mm center-positive plug into the board's power jack. Leads from a 
battery can be inserted in the Gnd and Vin pin headers of the POWER connector.  

The board can operate on an external supply of 6 to 20 volts. If supplied with less than 7V, however, the 5V 
pin may supply less than five volts and the board may be unstable. If using more than 12V, the voltage 
regulator may overheat and damage the board. The recommended range is 7 to 12 volts.  

The power pins are as follows:  

 VIN. The input voltage to the Arduino board when it's using an external power source (as opposed to 
5 volts from the USB connection or other regulated power source). You can supply voltage through 
this pin, or, if supplying voltage via the power jack, access it through this pin.  

 5V. The regulated power supply used to power the microcontroller and other components on the 
board. This can come either from VIN via an on-board regulator, or be supplied by USB or another 
regulated 5V supply.  

 3V3. A 3.3 volt supply generated by the on-board FTDI chip. Maximum current draw is 50 mA.  
 GND. Ground pins.  

 

The Atmega328 has 32 KB of flash memory for storing code (of which 2 KB is used for the bootloader); the 
ATmega328 has 32 KB, (also with 2 KB used for the bootloader). The Atmega328 has 2 KB of SRAM and 1 
KB of EEPROM (which can be read and written with the EEPROM library). 

 

Each of the 14 digital pins on the Duemilanove can be used as an input or output, using pinMode(), 
digitalWrite(), and digitalRead() functions. They operate at 5 volts. Each pin can provide or receive a 
maximum of 40 mA and has an internal pull-up resistor (disconnected by default) of 20-50 kOhms. In 
addition, some pins have specialized functions:  

 Serial: 0 (RX) and 1 (TX). Used to receive (RX) and transmit (TX) TTL serial data. These pins are 
connected to the corresponding pins of the FTDI USB-to-TTL Serial chip.  

 External Interrupts: 2 and 3. These pins can be configured to trigger an interrupt on a low value, a 
rising or falling edge, or a change in value. See the attachInterrupt() function for details.  

 PWM: 3, 5, 6, 9, 10, and 11. Provide 8-bit PWM output with the analogWrite() function.  
 SPI: 10 (SS), 11 (MOSI), 12 (MISO), 13 (SCK). These pins support SPI communication, which, 

although provided by the underlying hardware, is not currently included in the Arduino language.  
 LED: 13. There is a built-in LED connected to digital pin 13. When the pin is HIGH value, the LED is 

on, when the pin is LOW, it's off.  

http://www.arduino.cc/en/Reference/EEPROM
http://arduino.cc/en/Reference/PinMode
http://arduino.cc/en/Reference/DigitalWrite
http://arduino.cc/en/Reference/DigitalRead
http://arduino.cc/en/Reference/AttachInterrupt
http://arduino.cc/en/Reference/AnalogWrite


 

The Duemilanove has 6 analog inputs, each of which provide 10 bits of resolution (i.e. 1024 different values). 
By default they measure from ground to 5 volts, though is it possible to change the upper end of their range 
using the AREF pin and the analogReference() function. Additionally, some pins have specialized 
functionality:  

 I2C: 4 (SDA) and 5 (SCL). Support I2C (TWI) communication using the Wire library.  

There are a couple of other pins on the board:  

 AREF. Reference voltage for the analog inputs. Used with analogReference().  
 Reset. Bring this line LOW to reset the microcontroller. Typically used to add a reset button to 

shields which block the one on the board.  

See also the mapping between Arduino pins and Atmega328 ports.  

 

The Arduino Duemilanove has a number of facilities for communicating with a computer, another Arduino, or 
other microcontrollers. The ATmega328 provide UART TTL (5V) serial communication, which is available on 
digital pins 0 (RX) and 1 (TX). An FTDI FT232RL on the board channels this serial communication over USB 
and the FTDI drivers (included with the Arduino software) provide a virtual com port to software on the 
computer. The Arduino software includes a serial monitor which allows simple textual data to be sent to and 
from the Arduino board. The RX and TX LEDs on the board will flash when data is being transmitted via the 
FTDI chip and USB connection to the computer (but not for serial communication on pins 0 and 1).  

A SoftwareSerial library allows for serial communication on any of the Duemilanove's digital pins.  

The ATmega328 also support I2C (TWI) and SPI communication. The Arduino software includes a Wire 
library to simplify use of the I2C bus; see the documentation for details. To use the SPI communication, 
please see the ATmega328 datasheet.  

 

The Arduino Duemilanove can be programmed with the Arduino software (download). Select "Arduino 
Duemilanove w/ ATmega328" from the Tools > Board menu (according to the microcontroller on your 
board). For details, see the reference and tutorials.  

The ATmega328 on the Arduino Duemilanove comes preburned with a bootloader that allows you to upload 
new code to it without the use of an external hardware programmer. It communicates using the original 
STK500 protocol (reference, C header files).  

You can also bypass the bootloader and program the microcontroller through the ICSP (In-Circuit Serial 
Programming) header; see these instructions for details.  

http://arduino.cc/en/Reference/AnalogReference
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Reference/AnalogReference
http://arduino.cc/en/Hacking/PinMapping168
http://www.ftdichip.com/Drivers/VCP.htm
http://www.arduino.cc/en/Reference/SoftwareSerial
http://arduino.cc/en/Reference/Wire
http://arduino.cc/en/Main/Software
http://arduino.cc/en/Reference/HomePage
http://arduino.cc/en/Tutorial/HomePage
http://arduino.cc/en/Tutorial/Bootloader
http://www.atmel.com/dyn/resources/prod_documents/doc2525.pdf
http://www.atmel.com/dyn/resources/prod_documents/avr061.zip
http://arduino.cc/en/Hacking/Programmer


 

 

Rather then requiring a physical press of the reset button before an upload, the Arduino Duemilanove is 
designed in a way that allows it to be reset by software running on a connected computer. One of the 
hardware flow control lines (DTR) of the FT232RL is connected to the reset line of the ATmega328 via a 100 
nanofarad capacitor. When this line is asserted (taken low), the reset line drops long enough to reset the 
chip. The Arduino software uses this capability to allow you to upload code by simply pressing the upload 
button in the Arduino environment. This means that the bootloader can have a shorter timeout, as the 
lowering of DTR can be well-coordinated with the start of the upload.  

This setup has other implications. When the Duemilanove is connected to either a computer running Mac OS 
X or Linux, it resets each time a connection is made to it from software (via USB). For the following half-
second or so, the bootloader is running on the Duemilanove. While it is programmed to ignore malformed 
data (i.e. anything besides an upload of new code), it will intercept the first few bytes of data sent to the 
board after a connection is opened. If a sketch running on the board receives one-time configuration or other 
data when it first starts, make sure that the software with which it communicates waits a second after 
opening the connection and before sending this data.  

The Duemilanove contains a trace that can be cut to disable the auto-reset. The pads on either side of the 
trace can be soldered together to re-enable it. It's labeled "RESET-EN". You may also be able to disable the 
auto-reset by connecting a 110 ohm resistor from 5V to the reset line; see this forum thread for details.  

 

The Arduino Duemilanove has a resettable polyfuse that protects your computer's USB ports from shorts and 
overcurrent. Although most computers provide their own internal protection, the fuse provides an extra layer 
of protection. If more than 500 mA is applied to the USB port, the fuse will automatically break the 
connection until the short or overload is removed.  

 

The maximum length and width of the Duemilanove PCB are 2.7 and 2.1 inches respectively, with the USB 
connector and power jack extending beyond the former dimension. Three screw holes allow the board to be 
attached to a surface or case. Note that the distance between digital pins 7 and 8 is 160 mil (0.16"), not an 
even multiple of the 100 mil spacing of the other pins.  

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1213719666/all


 

Arduino can sense the environment by receiving input from a variety of sensors and can affect its 
surroundings by controlling lights, motors, and other actuators. The microcontroller on the board is 
programmed using the Arduino programming language (based on Wiring) and the Arduino 
development environment (based on Processing). Arduino projects can be stand-alone or they can 
communicate with software on running on a computer (e.g. Flash, Processing, MaxMSP). 

Arduino is a cross-platoform program. You’ll have to follow different instructions for your personal 
OS. Check on the Arduino site for the latest instructions.  http://arduino.cc/en/Guide/HomePage 

     

Once you have downloaded/unzipped the arduino IDE, you’ll need to install the FTDI Drivers to let 
your PC talk to the board. First Plug the Arduino to your PC via USB cable. 

 

Now you’re actually ready to “burn” your 
first program on the arduino board. To 
select “blink led”, the physical translation 
of the well known programming “hello 
world”, select 

File>Sketchbook> 
Arduino-0017>Examples> 
Digital>Blink 
 
Once you have your skecth you’ll 
see something very close to the 
screenshot on the right.  
 
In Tools>Board select 
 
Now you have to go to 
Tools>SerialPort  
and select the right serial port, the 
one arduino is attached to. 
 
 

 

 

 

 

 

 

http://www.arduino.cc/en/Tutorial/HomePage�
http://arduino.cc/en/Guide/Windows�
http://arduino.cc/en/Guide/MacOSX�
http://arduino.cc/en/Reference/HomePage
http://wiring.org.co/
http://www.processing.org/
http://arduino.cc/en/Guide/HomePage


 

 

 

 

 



 

1.      Warranties  
 
1.1     The producer warrants that its products will conform to the Specifications. This warranty lasts for one (1) years from the date of 
the sale. The producer shall not be liable for any defects that are caused by neglect, misuse or mistreatment by the Customer, including 
improper installation or testing, or for any products that have been altered or modified in any way by a Customer. Moreover, The 
producer shall not be liable for any defects that result from Customer's design, specifications or instructions for such products. Testing 
and other quality control techniques are used to the extent the producer deems necessary. 
 
1.2     If any  products fail to conform to the warranty set forth above, the producer's sole liability shall be to replace such products. The 
producer's liability shall be limited to products that are determined by the producer not to conform to such warranty. If the producer 
elects to replace such products, the producer shall have a reasonable time to replacements. Replaced products shall be warranted for a 
new full warranty period. 
 
1.3     EXCEPT AS SET FORTH ABOVE, PRODUCTS ARE PROVIDED "AS IS" AND "WITH ALL FAULTS." THE PRODUCER 
DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, REGARDING PRODUCTS, INCLUDING BUT NOT LIMITED TO, 
ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE 
 
1.4     Customer agrees that prior to using any systems that include the producer products, Customer will test such systems and the 
functionality of the products as used in such systems. The producer may provide technical, applications or design advice, quality 
characterization, reliability data or other services. Customer acknowledges and agrees that providing these services shall not expand or 
otherwise alter the producer's warranties, as set forth above, and no additional obligations or liabilities shall arise from the producer 
providing such services. 
 
1.5     The Arduino products are not authorized for use in safety-critical applications where a failure of the product would reasonably 
be expected to cause severe personal injury or death. Safety-Critical Applications include, without limitation, life support devices and 
systems, equipment or systems for the operation of nuclear facilities and weapons systems. Arduinoproducts are neither designed 
nor intended for use in military or aerospace applications or environments and for automotive applications or environment. Customer 
acknowledges and agrees that any such use of Arduino products which  is solely at the Customer's risk, and that Customer is solely 
responsible for compliance with all legal and regulatory requirements in connection with such use. 
 
1.6 Customer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related 
requirements concerning its products and any use of Arduino products in Customer's applications, notwithstanding any applications-
related information or support that may be provided by the producer. 
 
 
2.       Indemnification 
 
The Customer acknowledges and agrees to defend, indemnify and hold harmless the producer from and against any and all third-party 
losses, damages, liabilities and expenses it incurs to the extent directly caused by: (i) an actual breach by a Customer of the 
representation and warranties made under this terms and conditions or (ii) the gross negligence or willful misconduct by the Customer. 
 
3.        Consequential Damages Waiver 
 
In no event the producer shall be liable to the Customer or any third parties for any special, collateral, indirect, punitive, incidental, 
consequential or exemplary damages in connection with or arising out of the products provided hereunder, regardless of whether the 
producer has been advised of the possibility of such damages. This section will survive the termination of the warranty period. 
 
 
4.      Changes to specifications 
 
The producer  may make changes to specifications and product descriptions at any time, without notice. The Customer must not rely on 
the absence or characteristics of any features or instructions marked "reserved" or "undefined." The producer reserves these for future 
definition and shall have no responsibility whatsoever for conflicts or incompatibilities arising from future changes to them. The product 
information on the Web Site or Materials is subject to change without notice. Do not finalize a design with this information. 

 

 

The producer of Arduino  has joined the Impatto Zero® 
policy of LifeGate.it. For each Arduino board produced is 
created / looked after half squared Km of Costa Rica’s 
forest’s. 

 

http://servizi.lifegate.it/newimpattozero/prodotti.asp?p=&id=944�

